Updater API fixed

From: Tomaz Solc <tomaz.solcREMOVE@THIStablix.org>
Date: Sun Apr 23 2006 - 20:27:51 CEST

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi everyone.

I've fixed the error that was causing problems with updater functions.
The fix is in the CVS repository now.

Unfortunately this broke the backward compatibility with modules written
for 0.3.1 that used updater functions. If anyone is using any
home-brewed modules: you will have to rewrite some parts of these
modules in order to use them with releases after 0.3.1. The good news is
that in most cases this should be trivial (see the section relevant
section in the CVS version of Modules HOW-TO). The two modules in the
distribution that used updater function are already updated.

If you have any problems with the new API, please report them to the
mailing list.

Best regards
Tomaz Solc
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFES8clsAlAlRhL9q8RAnt9AKDOjagzLn6eyrU4nlGtcoacusbs3wCgxNAf
w4GE29QRlpoQ81HAFK5Wyhk=
=DUmM
-----END PGP SIGNATURE-----
Received on Sun Apr 23 20:27:55 2006

This archive was generated by hypermail 2.1.8 : Mon Apr 24 2006 - 06:28:34 CEST